Invalid Client Version

iZULASiZULAS Beginner
edited June 12 in CrossFire Support

When opening the game, the client gives an error. I deleted the game and reinstalled it, nothing changed. I watched the version.ini related videos from Youtube and tried it, it didn't work. It was giving disconnect error 1-2 months ago, that problem was related to servers, now can anyone help who knows what is causing this problem?

Comments

  • sfsdcdsfesfsdcdsfe Beginner

    I fixed this problem(sorry i use google translate).
    This issue occurs because the Windows 10 changes the game files and installer files. Сhanging the version.in won't help, since the files don't match anymore. And old installer crossfire dont work. How to fix:
    Step 1: uninstall old game/installer/documents and download NEW installer and install new game.
    Step 2: Open patcher_cf.exe and wait when game update and ready to play. Caution! DONT START PLAY GAME! We dont fix game.
    (Now we work with version.ini in the game folder. We need to prevent the system from changing this file.Use read only this cant help, because over time this setting stops working)
    Step 3: Right-click version.ini=>properties=>security=>edit. Here u need find "write" and deny. U need do this for all user!!! Now widdows cant change this file! Open game now and play!

    But not everything is so good! When the game is updated, the system will not be able to change this version.ini. You will enter an un-updated game and get an error 31_19. This means that the game has not been updated.
    You need to update all over again. New installer and new game and deny write version.ini. Nothing to do.
    Easy way install two windows- windows 7 and windows 10 and play in windows 7!
    Good luck and write here if i help you!

  • iZULASiZULAS Beginner

    @sfsdcdsfe said:
    I fixed this problem(sorry i use google translate).
    This issue occurs because the Windows 10 changes the game files and installer files. Сhanging the version.in won't help, since the files don't match anymore. And old installer crossfire dont work. How to fix:
    Step 1: uninstall old game/installer/documents and download NEW installer and install new game.
    Step 2: Open patcher_cf.exe and wait when game update and ready to play. Caution! DONT START PLAY GAME! We dont fix game.
    (Now we work with version.ini in the game folder. We need to prevent the system from changing this file.Use read only this cant help, because over time this setting stops working)
    Step 3: Right-click version.ini=>properties=>security=>edit. Here u need find "write" and deny. U need do this for all user!!! Now widdows cant change this file! Open game now and play!

    But not everything is so good! When the game is updated, the system will not be able to change this version.ini. You will enter an un-updated game and get an error 31_19. This means that the game has not been updated.
    You need to update all over again. New installer and new game and deny write version.ini. Nothing to do.
    Easy way install two windows- windows 7 and windows 10 and play in windows 7!
    Good luck and write here if i help you!

    I understood thank you. But as far as I understand, the game does not run smoothly on windows 10, so I have to play on windows 7. But since microsoft has ended support for windows 7, it is not possible for me to install it. So I will pause playing until this issue is fixed. It has been confirmed that Crossfire is not working properly on windows 10. Thank you again.

Sign In or Register to comment.