[Guide] [How to fix] Unable to save in-game settings? Come here

SirPanoCFESSirPanoCFES Worthy
edited June 4 in CrossFire Guides
I am posting this thread because many people tend to have this problem regularly, particularly on Discord.

You can test 3 options: One should work.

#1. Keyboard not compatible with CrossFire West.

This method (#1) only works and applies if you receive this message:
L3Pezl1.png

If you don't get it, please bypass this step. Go to #2 or #3.

Important:

TIElAP3.png

If you are using a QWERTZ (German) keyboard, please ensure you tick the box saying "German" in the game options. If you are using a QWERTZ (German) keyboard and the English box is ticked/checked/marked (or as you want to call it) in the game options, you will receive the previous message.

Both must be on the "same page."

QWERTY = English (at in-game settings and the Keyboard layout on Windows.)
QWERTZ = German (at in-game settings and the Keyboard layout on Windows.)

Consider the following: CrossFire West only supports English (US) QWERTY keyboards and German QWERTZ keyboards (If you have not selected the correct option in-game settings, this will not work).

It will help if you have a real English (US) QWERTY keyboard. You can try this method, although it is recommended to have a real one:

Check the configuration on Windows (Control Panel / Language).
Step 1: Go to the Start button and open "Control Panel."
Step 2: Choose the option "Clock, Language, and Region."
Step 3: Select "Regional and Language Options," and in the "Installed Services" section, click "Add."
Step 4: If your keyboard is set to "French" (AZERTY) change it to "English US/UK" (QWERTY) or German (QWERTZ)."
Step 5: In the "Keyboard" section, choose "English (US) QWERTY and apply the changes by clicking "OK."

This is AZERTY:

CWRjfMR.png

This is QWERTZ:

Nm4dGxu.png

This is QWERTY:

P3mYYsB.png

#2. System.dat. Uncheck the "read-only" property

DQ2a6Jw.png

Uncheck that box (Read-only). You may have that file (system.dat) set to "read-only," and the game cannot write into it. If so, that's why the game can't modify or change these parameters on the settings.

Steps:
  1. Go to the CrossFire folder on My documents.
  2. My Documents, please.
  3. Find the file called "System.dat."
  4. Right-click/properties and uncheck "read-only" and try clicking "Save changes."

#3 Windows Defender.
If these steps do not work, try this method: Windows Defender has a new option or feature called “Controlled Folder Access (CFA)” on Windows. You must turn off/disable this feature on Windows Defender Security Center or another antivirus. By doing this, you will be able to save the game settings again.

PD: Make sure you do it outside the game.
#4 Microsoft OneDrive.
It's simply: disable/turn off Microsoft OneDrive on Windows.

Comments

  • SerxzSerxz Beginner
    I already have the QWERTY keyboard English and I still receive the message to check my keyboard type,, the system.dat file in documents also the read-only is unchecked.. the controlled folder access of the anti-virus is already turned off.. however nth seemed to resolve the issue,, any other suggestions?
Sign In or Register to comment.