Failed to download version.ini file

I have this problem.. I've looked around and can't find any answers to this topic. I hope someone could help me with this, it ran perfectly last night.. now when I tried to start it today it didn't work.

Done so far to try to fix this:

Uninstalled [X]
Insalled agan [X]
Updated drivers [X]
Restart computer [X]
Restarted internet connection [X]

Comments

  • I get the exact same errors trying to run the game. Worked perfectly this morning, but since this afternoon I haven't been able to play at all. Any ideas/News?
  • Bro just wait
    Z8games are probaly working on servers
  • Well, I think both of us would like to know if this is an issue for everyone or just us. Can't see any other posts about it and this has been going on for at least 6hrs now.

    And a 6hr upgrade without telling anyone doesn't sound like z8games
  • To fix this problem simply run your crossfire as an Administrator
    To do this...Right Click the CrossFire Icon and Click Run as Administrator

    Hope this will fix it =)
  • yeah I tried that a couple of times already, it doesn't do any difference. Tried the same thing with the patcher directly, same thing.
  • Stocken2Stocken2 Beginner
    Been trying forever now, if they are doing something with the servers, why don't they announce this in the launcher for the game? Would be much appriciated if they did..
  • Thinking they might have load balancers on there main server, so depending on from where in the world you connect you're directed to a specific server. Since the problem seem to be very limited right now (last time this happen to everyone there was a storm on the forum hehehe)

    @Stocken2 You wouldn't happen to be in Scandinavia would you?
  • Stocken2Stocken2 Beginner
    Yes, I live in sweden.. this means I cant play anymore..?
  • Last time I think this problem lasted for 24hrs or so. So at least we have found one thing we have in common, I'm from Sweden to. Hopefully they haven't blocked all Swedish players just for fun. :D
  • I've been fiddling around now in the /CrossFire/ folder.

    Seems like the cf_patcher uses a link located in the LOCALINFO.DAT file. This is the link for the version.ini.

    But this link points to a non existing file ( http://cfpatch.z8game.com/download/version.ini )
    So it will never work. Either z8games fekked up and removed the version.ini from that site or the patcher guys got the wrong URL.
  • dj_Rolfdj_Rolf Beginner
    Idd im from sweden to, rly hope it is a local thing and not some mayor **** :)
  • I tried the URL http://cfpatch.z8game.com/download/version.ini on http://downforeveryoneorjustme.com/ and that URL will not work for anyone so... its time for z8games to do something about that link.
  • After some more investigation, the problem seem to be to access websites hosted on servers located on the east coast of USA and Canada. Tried a couple now, even huge sites like www.imdb.com (hosted in NY), all of them are unreachable. Guessing there's a problem with at least one of the transatlantic cables. Not much z8games can do about that. :)
  • Haven't played the game in awhile, thought I'd pick it up again. I get this error... I come here real fast, no help.

    I notice my firewall is being funny, I turn it off, reboot and it works.

    It's firewall related, the patcher is trying to reach Z8 to check the 'version.ini' and it can't.

    You can keep your firewall on too, just make sure you're allowing Crossfire to do w/e it wants to.
  • Stocken2Stocken2 Beginner
    Yea, neither MSN or hotmail works for me, same with ninjavideo etc, but google, youtube, xfire and so on works perfectly..
  • Stocken2Stocken2 Beginner
    Beanster85 wrote: »
    Haven't played the game in awhile, thought I'd pick it up again. I get this error... I come here real fast, no help.

    I notice my firewall is being funny, I turn it off, reboot and it works.

    It's firewall related, the patcher is trying to reach Z8 to check the 'version.ini' and it can't.

    You can keep your firewall on too, just make sure you're allowing Crossfire to do w/e it wants to.


    Well i neither got my firewall or anti virus up and running at all, its like starship trooper said.. all traffic from USA is blocked or problems with..
  • Well, I don't run firewalls nor anti virus. The URL the "version.ini" is located on is inaccessable.

    But if someone would just share there latest 'version.ini' I bet we could get this to work. :)
  • I'm not talking about those links.

    I'm saying, make sure all protection and firewalls are off, and if they already are. Make sure Windows Firewall has an exception for all CrossFire stuff.

    Just start the game and you won't get the error, those URLs are not needed.

    Worked for me, easy fix.
  • [X] Firewall OFF
    [X] Exception for all Crossfire exe's and DLL's
    [X] No anti-virus or similar.
    [X] Administrator rights on all executables

    But you're wrong, the cf_patcher when looking at it through a debugger fails on just that, it tries to fetch the 'version.ini' from the website mentioned above, the URL inside the localinfo.dat file.

    After 120sec there's a timeout in cf_patchers.exe and that's when you get " Failed to download version.ini ".

    So for as long as we can't connect to a website containing the version.ini we wont be able to run the game. :(
  • Stocken2Stocken2 Beginner
    Beanster85 wrote: »
    I'm not talking about those links.

    I'm saying, make sure all protection and firewalls are off, and if they already are. Make sure Windows Firewall has an exception for all CrossFire stuff.

    Just start the game and you won't get the error, those URLs are not needed.

    Worked for me, easy fix.

    This is not the issue we have. Every connection between USA and Sweden is blocked for a reason or just down, no website from USA works for us today. It started around 2-3 pm today. It's proberly some net error, but 60-70% of the ones i know, and swedish forums has posted this issue.
  • i have the same problem too
  • i don't know what to do
Sign In or Register to comment.